Автор Тема: Помогите с AutoPrefixer - не работает.  (Прочитано 4164 раз)

weranda

  • Newbie
  • *
  • Сообщений: 2
Помогите с AutoPrefixer - не работает.
« : Июня 05, 2014, 10:57:48 »
Всем привет.
Есть win7*64, ST2 и Autoprefixer (node.js установлен).
Запускаю и появляется сообщение:
Autoprefixer
'ascii' codec can't decode byte 0xd1 in position 0: ordinal not in range(128)

Как побороть эту ошибку чтобы AutoPrefixer заработал?

Loac

  • Administrator
  • Hero Member
  • *
  • Сообщений: 605
Re: Помогите с AutoPrefixer - не работает.
« Ответ #1 : Июня 05, 2014, 11:21:13 »
Обычно все ошибки в ST, связанные с кодировкой, из-за русских символов в именах директорий и файлов.

Имя пользователя в системе кириллицей?

weranda

  • Newbie
  • *
  • Сообщений: 2
Re: Помогите с AutoPrefixer - не работает.
« Ответ #2 : Июня 05, 2014, 11:27:06 »
Да, кириллицей.
Сменить возможности нет, так как очень много ПО завязано на эту учетную запись.

Сейчас все же попробовал сменить имя учетной записи на латиницу и ничего не поменнялось, ошибка всё та же.
« Последнее редактирование: Июня 05, 2014, 11:29:10 от weranda »

Loac

  • Administrator
  • Hero Member
  • *
  • Сообщений: 605
Re: Помогите с AutoPrefixer - не работает.
« Ответ #3 : Июня 05, 2014, 12:04:19 »
Сменив имя пользователя, путь до папки, где у лежат плагины, скорее всего не изменился.

Пока есть доступ только в Windows XP. В ней с русскими символами происходит страшное. Дома проверю на 7.

Пока советую попробовать портейбл версию ST, положив ее куданибудь в C:\SublimeText. Чтобы наверняка.
« Последнее редактирование: Июня 05, 2014, 12:07:44 от Loac »

Loac

  • Administrator
  • Hero Member
  • *
  • Сообщений: 605
Re: Помогите с AutoPrefixer - не работает.
« Ответ #4 : Июня 06, 2014, 10:47:26 »
Проверил на Windows 7. Ошибка из-за кириллицы в имени директории по пути до SublimeText.