Автор Тема: Emmet LiveStyle. Не коректно работает  (Прочитано 14851 раз)

mohten

  • Newbie
  • *
  • Сообщений: 13
Emmet LiveStyle. Не коректно работает
« : Октября 31, 2013, 21:02:31 »
Такая проблема: при редактировании кода в саблайме chrome не реагирует пока не сохраню файл в саблайме и не обновлю страницу. В плагине браузера видно что файлы открыты в саблайме, не пойму что не так толи браузер не реагирует толи сам саблайм тупит?

Loac

  • Administrator
  • Hero Member
  • *
  • Сообщений: 605
Re: Emmet LiveStyle. Не коректно работает
« Ответ #1 : Октября 31, 2013, 21:36:17 »
Попробуй добавить в файл настроек плагина для ST

{"debug": true}
может быть консолька покажет какую-нибудь гадость.

Запусти Package Control upgrade и проверь, чтобы в Chrome была последняя версия расширения.
« Последнее редактирование: Октября 31, 2013, 21:39:59 от Loac »

mohten

  • Newbie
  • *
  • Сообщений: 13
Re: Emmet LiveStyle. Не коректно работает
« Ответ #2 : Октября 31, 2013, 21:45:27 »
Не знаю так ли я добавил строку?
Цитировать
{
   "fallback_encoding": "Cyrillic (Windows 1251)",
   "font_size": 13,
          {"debug": true}
   "ignored_packages":
   [
      "Vintage"
   ]
}
Но выскочило это:
Цитировать
Error trying to parse settings: Experected value in Packades\User\Preferences.subleme-settings:4:11

Плиз тыкните пальцем куда именно вставить туплю.
« Последнее редактирование: Октября 31, 2013, 21:53:24 от mohten »

Алексей

  • Jr. Member
  • **
  • Сообщений: 62
Re: Emmet LiveStyle. Не коректно работает
« Ответ #3 : Октября 31, 2013, 22:31:40 »
{"debug": true}

Отредактируй и оставь на месте .
Удали скобки {} и после true поставь запятую .
Должно быть так

{
   "fallback_encoding": "Cyrillic (Windows 1251)",
   "font_size": 13,
   "debug": true,
   "ignored_packages":
   [
      "Vintage"
   ]
}

Алексей

  • Jr. Member
  • **
  • Сообщений: 62
Re: Emmet LiveStyle. Не коректно работает
« Ответ #4 : Октября 31, 2013, 22:36:08 »
Loac
С настройками я вроде разобрался , а вот с плагинами чет не как (( .
Ставил Phpcs ?
Где бы найти почитать за него ? Help о всемогущий админ ))

mohten

  • Newbie
  • *
  • Сообщений: 13
Re: Emmet LiveStyle. Не коректно работает
« Ответ #5 : Октября 31, 2013, 23:08:30 »
Спасибо! Я позже так и подумал но сомневался в каком файле.
Запустил Package Control upgrade
выдало это:Packade Control
There are no packades ready for upgrade

Сейчас только заметил что при редактировании engine.css всё работает но styles.css не хотит изменять вид страницы пока не обновиш
« Последнее редактирование: Октября 31, 2013, 23:22:01 от mohten »

Алексей

  • Jr. Member
  • **
  • Сообщений: 62
Re: Emmet LiveStyle. Не коректно работает
« Ответ #6 : Октября 31, 2013, 23:30:00 »
У меня у самого не получилось настроить LiveStyle ))) , решил отметиться в теме чтобы последить  :-[  ;D

А на firefox пробовал ? Где то видел , может даже здесь , что chrome моросит при работе с LiveStyle .
« Последнее редактирование: Октября 31, 2013, 23:33:18 от Алексей »

mohten

  • Newbie
  • *
  • Сообщений: 13
Re: Emmet LiveStyle. Не коректно работает
« Ответ #7 : Октября 31, 2013, 23:42:04 »
Разве есть на мозиле такой плагин? вроде как только на хроме и сафари

Алексей

  • Jr. Member
  • **
  • Сообщений: 62
Re: Emmet LiveStyle. Не коректно работает
« Ответ #8 : Ноября 01, 2013, 00:02:26 »
Разве есть на мозиле такой плагин? вроде как только на хроме и сафари
Да . googl молчит по поводу firefox. Туплю значит ))

mohten

  • Newbie
  • *
  • Сообщений: 13
Re: Emmet LiveStyle. Не коректно работает
« Ответ #9 : Ноября 01, 2013, 00:12:05 »
Думаю уже попробывать на сафари хотя так не охото ставить ещё браузер привык на опере потом перебрался на фаерфокс хром только из за плагина поставил теперь ещё и сафари, както решится админ что нибудь придумает))) у меня была уже эта ошибка я потом всё сносил и переустанавливал помогло на время потом опять начало глючить переустановка уже не помогает. Но ведь при редактировании engine.css всё работает а styles.css нечерта где тут собака зарыта.

mohten

  • Newbie
  • *
  • Сообщений: 13
Re: Emmet LiveStyle. Не коректно работает
« Ответ #10 : Ноября 01, 2013, 00:21:58 »
Вроде бы нашол причину у меня в стилях стояла лишняя закрывающая скобка, может и из за неё так как после правки вроде пока работает)))) ураааа! Всем спасибо за помощ.

Алексей

  • Jr. Member
  • **
  • Сообщений: 62
Re: Emmet LiveStyle. Не коректно работает
« Ответ #11 : Ноября 01, 2013, 00:30:51 »
Напиши лучше как ставил , как настраивал , че за скобки . А то себе сделал а другим ?

mohten

  • Newbie
  • *
  • Сообщений: 13
Re: Emmet LiveStyle. Не коректно работает
« Ответ #12 : Ноября 01, 2013, 00:42:45 »
В хроме у плагина внизу справа показывает значёк и количество ошибок в стилях и показывает где именно в какой строке файла css ошибка я исправил у меня была лишняя закрываощая скобка примерно так:
{

}}
после правки всё заработало, по ходу плагин плохо переваривает стили с ошибками типа лишний закрывающиеся или наоборот теги.

Алексей

  • Jr. Member
  • **
  • Сообщений: 62
Re: Emmet LiveStyle. Не коректно работает
« Ответ #13 : Ноября 01, 2013, 00:54:27 »
А как их вместе связать ? Браузер и сублим . Просто ставишь плагины в браузер и subl и все ?

mohten

  • Newbie
  • *
  • Сообщений: 13
Re: Emmet LiveStyle. Не коректно работает
« Ответ #14 : Ноября 01, 2013, 00:56:29 »